ICPC训练联盟2021寒假冬令营(5)H-排名

ICPC训练联盟2021寒假冬令营(5)H-排名

发表于 2021-01-23

1.题目

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。

Input

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。

Output

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
14
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output

1
2
3
4
5
6
7
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

2.实现代码

本题输入口太多!!!注意搞清楚函数名和输入顺序!!!

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include <iostream>
#include <algorithm>
using namespace std;
#define N 1005
int que[15];
struct ks
{
char name[25];//考生号
int num;//解决问题总数
int sum;//分数
}stu[N];
bool cmp(const ks &a,const ks &b)
{
if(a.sum==b.sum)
return strcmp(a.name,b.name)<0?1:0;//比较考生号
else
return a.sum>b.sum;
}
int main()
{
int stu_num,text_num,line,a,cnt;//stu_num考生人数,text_num考题数
while(cin>>stu_num&&stu_num)
{
cnt=0;
int j;
cin>>text_num>>line;
for(j=1;j<=text_num;j++)
cin>>que[j];
for(j=1;j<=stu_num;j++)
{
stu[j].sum=0;//初始化成绩求和
cin>>stu[j].name>>stu[j].num;
while(stu[j].num--)
{
cin>>a;//做对的题号
stu[j].sum+=que[a];//求总成绩
}
if(stu[j].sum>=line)
cnt++;//计算过分数线的人树
}
sort(stu+1,stu+1+stu_num,cmp);//排序
cout<<cnt<<endl;
for(j=1;j<=stu_num;j++)
{
if(stu[j].sum>=line)
cout<<stu[j].name<<" "<<stu[j].sum<<endl;
else
break;
}
}
return 0;
}